General Discussion     Tech Questions     Parts & Services     Suggestions/Ideas     Help & Website Instructions     Blogs    

Truck & Transportation History

Home Search Tags


Cummins Engine Knock

Posted By dayradebaugh Sunday, October 10, 2021 12:37 PM
Add to Favorites2
Author Message
dayradebaugh
 Posted Sunday, October 10, 2021 12:37 PM
.

. - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation)

Group: Forum User
Last Active: Monday, November 15, 2021 2:49 AM
Posts: 83, Visits: 1,061
I have an '80 Autocar with a 230 Cummins which has been running fine. Took it in for a full service (crankcase, trans oil and fuel filter). Got it back and now it knocks after I start it and pop the accelerator. I had assumed it was because there was air in the fuel system after the fuel filter change, but that didn't help?

This seems strange, and directly related to the service, but the mechanic just changed fluids. Any good ideas out there?

Thanks
Newto
 Posted Sunday, October 10, 2021 9:05 PM
.

. - (28,507 reputation). - (28,507 reputation). - (28,507 reputation). - (28,507 reputation). - (28,507 reputation). - (28,507 reputation). - (28,507 reputation). - (28,507 reputation). - (28,507 reputation)

Group: Forum User
Last Active: 2 days ago @ 9:54 PM
Posts: 125, Visits: 2,520
Is it hard to start?......as in winds over longer than it used to before firing and when it does fire up does it hunt.....(revs go up and down) & if you hit the throttle slow response?

Lots of questions ......sorry....

If its doing any of the above and it never used to before the service then suspect the fuel filter maybe isn't tight?.....try tightening by hand.....what brand filter is it?

that will do to begin with......

cheers,

Newto
Newto
 Posted Sunday, October 10, 2021 9:05 PM
.

. - (28,507 reputation). - (28,507 reputation). - (28,507 reputation). - (28,507 reputation). - (28,507 reputation). - (28,507 reputation). - (28,507 reputation). - (28,507 reputation). - (28,507 reputation)

Group: Forum User
Last Active: 2 days ago @ 9:54 PM
Posts: 125, Visits: 2,520
Is it hard to start?......as in winds over longer than it used to before firing and when it does fire up does it hunt.....(revs go up and down) & if you hit the throttle slow response?

Lots of questions ......sorry....

If its doing any of the above and it never used to before the service then suspect the fuel filter maybe isn't tight?.....try tightening by hand.....what brand filter is it?

that will do to begin with......

cheers,

Newto
dayradebaugh
 Posted Monday, October 11, 2021 5:18 AM
.

. - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation)

Group: Forum User
Last Active: Monday, November 15, 2021 2:49 AM
Posts: 83, Visits: 1,061
Seems to start fine, and idle OK. It's just when you blip the throttle, it knocks. Since nothing internal was done to engine, I have to believe it's related to the fuel system.

Thanks
dayradebaugh
 Posted Wednesday, October 27, 2021 2:02 AM
.

. - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation)

Group: Forum User
Last Active: Monday, November 15, 2021 2:49 AM
Posts: 83, Visits: 1,061
The plot thickens. I had a diesel mechanic come out and troubleshoot the engine, which barely starts now. He concluded that only 2 of the injectors were working. We went looking for the engine serial number, and the data plate is gone. However, we did find the CPL on the fuel pump, which is 207 8428. Local Cummins dealer apparently couldn't find a set of injectors.

Should these be available for what is a '80's vintage Cummins? I would guess that this is a Big Cam I, II or III, at least from an Internet search.

Any suggestions appreciated.
dayradebaugh
 Posted Wednesday, October 27, 2021 2:14 AM
.

. - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation)

Group: Forum User
Last Active: Monday, November 15, 2021 2:49 AM
Posts: 83, Visits: 1,061
Further research shows that this CPL designates a PT-270 pump and M-3018843 injector.
terry sillik
 Posted Wednesday, October 27, 2021 7:59 AM
ATHS Member

ATHS Member - (14,813 reputation)ATHS Member - (14,813 reputation)ATHS Member - (14,813 reputation)ATHS Member - (14,813 reputation)ATHS Member - (14,813 reputation)ATHS Member - (14,813 reputation)ATHS Member - (14,813 reputation)ATHS Member - (14,813 reputation)ATHS Member - (14,813 reputation)

Group: Forum User
Last Active: 15 hours ago
Posts: 160, Visits: 8,669
dayradebaugh (10/27/2021)
Further research shows that this CPL designates a PT-270 pump and M-3018843 injector.
I have 6 cummins rebuilt injectors still in the box, #3018840PX would these work? If so let me know. terry they said on the big mack website these were for a power torque 270?
Wednesday, October 27, 2021 8:01 AM by terry sillik
jimfols
 Posted Wednesday, October 27, 2021 12:46 PM
.

. - (26,570 reputation). - (26,570 reputation). - (26,570 reputation). - (26,570 reputation). - (26,570 reputation). - (26,570 reputation). - (26,570 reputation). - (26,570 reputation). - (26,570 reputation)

Group: Forum User
Last Active: Yesterday @ 1:35 PM
Posts: 86, Visits: 2,359
I would question what the new filter was filled with during the filter change.

Over 60 Years of Service Dedicated to Trucking in America
PT Fuel Systems Forever

Jim
dayradebaugh
 Posted Thursday, October 28, 2021 1:40 PM
.

. - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation)

Group: Forum User
Last Active: Monday, November 15, 2021 2:49 AM
Posts: 83, Visits: 1,061
I think I have found some, thanks.
dayradebaugh
 Posted Thursday, October 28, 2021 1:41 PM
.

. - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation). - (17,681 reputation)

Group: Forum User
Last Active: Monday, November 15, 2021 2:49 AM
Posts: 83, Visits: 1,061
You may be right, but I think it's too late for that. In fact, I drove it home from the shop (10 mi) and it was just fine.

Similar Topics

Expand / Collapse

Reading This Topic

Expand / Collapse

Back To Top